Составить программу вычисления суммы четных чисел от 1 до n. найдите среднее арифметическое этих чисел
Составить программу вычисления суммы четных чисел от 1 до n. найдите среднее арифметическое этих чисел
Ответ(ы) на вопрос:
program help; var a,n,x,summa:integer; begin x:=0; a:=1; summa:=0; readln (n); while a<=n do begin if a mod 2 =0 then summa:=summa+a; if a mod 2 =0 then x:=x+1; a:=a+1; end; summa:=summa div x; writeln (summa); end.
Не нашли ответ?
Похожие вопросы