Контрольная работа: Примеры решения задач по программированию

int i,a;

int mas[5]; // объявлениемассива mas

printf("Введите элементы массива \n");

for(i=0;i<5;i++) // использование вложенной структуры повторения for для

{

scanf("%d",&mas[i]); // заносим значение в массив

a=mas[0];

}

printf(" Вывод элементов масива \n");

for(i=0;i<5;i++) // использование вложенной структуры повторения for для

{

printf("%d",mas[i],"\n"); // вывод суммы элементов массива mas на экран

}

for(i=1;i<4;i++) // использование вложенной структуры повторения for для if (i++<a) cout<<"Массив не является возрастающей последовательностью ";

// использование else-if конструкции

}

Результаты работы программы

Введите значения : 4 7 5 6 8

Результат: 4 7 5 6 8 Массив не является возрастающей последовательностью

Выводы по лабораторной работе

В ходе выполнения задания была составлена схема машинного алгоритма по условию задачи, написан код программы и получены результаты работы программы. В результате выполнения работы были закреплены практические навыки построения простой программы на языке программирования C/C++, в которой были объявлен массив MAS . Организован ввод значений переменных с помощью оператора потокового ввода, произведен расчет значений массива на возрастающую последовательность и организован вывод результата на экран с помощью оператора потокового вывода.

ЗАДАНИЕ № 4

ФУНКЦИИ В C / C ++. УКАЗАТЕЛИ НА ФУНКЦИИ. ПЕРЕГРУЗКА ФУНКЦИЙ. ШАБЛОНЫ ФУНКЦИЙ

Цель работы

Закрепление практических навыков построения программы на языке C/C++ с использованием функций, указателей на функции, массивов указателей на функции, рекурсивных функций, функций со списком переменной длины, параметров, используемых по умолчанию, аргументов командной строки, встроенных функций, перегруженных функций и шаблонов функций.

Постановка задачи

Написать программу, в которой необходимо определить массив указателей на функции. Вводить цифру, определяющую какую функцию надо выполнить: 0-найти минимальное число, 1-найти максимальное число, 2-вычислить сумму чисел, 3-вычислить разность чисел, 4-найти произведение чисел, 5-найти частное чисел, 6-завершить работу. Выполнить соответствующую функцию, используя указатель на нее, и вывести результаты на экран. В программе предусмотреть использование прототипа функции.

Листинг программы на языке C ++

//---------------------------------------------------------------------------

К-во Просмотров: 284
Бесплатно скачать Контрольная работа: Примеры решения задач по программированию