Контрольная работа: Программирование решения задач

readln(c);

if c=0 then break;

until false

end.

Рис.2. Результаты рабаты программы для задачи 2

Задача №3

Татьяна Ларина, читая очередной французский роман, подсчитала сумму номеров прочитанных страниц. Написать программу, определяющую номер последней прочитанной страницы.

Решение

1. Анализ введенных с клавиатуры исходных данных

2. Решение с помощью арифметической прогрессии

3. Выведение условия для выхода

4. Выводрезультатов

program Project2;

{$APPTYPE CONSOLE}

uses

SysUtils;

var

sum,i,n:integer;

begin

write('enter n:');

readln(n);

i:=0;

repeat

inc(i);

sum:=sum+i;

until sum>=n;

writeln('otvet',i);

readln(i);

end.


Рис. 3. Результаты работы программы для задачи 3

Задача №4

Найти все двузначные числа, сумма цифр которых не меняется при умножении на 2,3,4,5,6,7,8,9.

Решение

Для написания этой программы воспользуемся функцией sumc (умножение I на любое однозначное число ). Для проверки кратности удобно использовать операцию mod, позволяющую определить остаток при делении целых чисел. Так как числа двузначные, то цикл будет от 10 до 99.

programProject4;

К-во Просмотров: 604
Бесплатно скачать Контрольная работа: Программирование решения задач