Курсовая работа: Составить программу на языке Turbo Pascal для параллельной сортировки чисел

Составить программу на языке TurboPascal для параллельной сортировки множества из n чисел, где n- мощность множества, состоящего из букв фамилии, n>2.

Оглавление

Условие задачи

Описание программы

Схема алгоритма

Текст Программы

Примеры выполнения

Список литературы

Описание программы

Тело программы начинается с цикла for, создающего верхнюю строчку, состоящую из символов:

{ fori:=1 to 35 do

begin

textcolor(1);

write(chr(5));

end; }

где 35- произвольное число, длина строки; τextcolor – процедура, задающая цвет нужному фрагменту программы. Далее оформление создаётся аналогичным образом.

Для начала работы программы вводим фамилию. Она считывается в переменную fam типа string. Затем требуется создать по количеству символов из этой введенной фамилии одномерный массив типа integer. Для этого сначала требуется посчитать количество символом - это легко можно сделать с помощью строковой функции Length: e:=Length(fam), где e-переменная типа integer.

Далее требуется проверить введённую фамилию, на наличие цифр. Для этого используется функция Val: val(fam[i],n,kod). Эту функцию выполняем в цикле for, так как нужно проверить каждый символ в фамилии. Потом делаем проверку переменной kod в условном операторе if:

{fori:=1 toedo

begin

val(fam[i],n,kod);

if kod=0 then

begin

writeln ('neverno vvedena familia')

f:=false; end;}

Если kod=0 значит в нашей фамилии содержится цифра.

Всё выше описанное происходит в цикле repeat, условием выхода которого является f=false. В начале этого цикла мы поднимаем флажок, т.е. f=true. Далее, как описано во фрагменте кода выше, если kod=0 мы опускаем флажок. Это нужно для того, чтобы получилось зацикливание, и пользователь мог, в случае неправильного ввода фамилии, сделать это снова. Если же f=true после прохождения по циклу, цикл завершит свою работу.

После этого цикла создаётся удобный интерфейс, позволяющий пользователю не запутаться в том, что нужно ввести. Далее непосредственно начинается сортировка массива, двумя способами: методом вставки и методом пузырька.

k:=0;

{metod vstavki}

--> ЧИТАТЬ ПОЛНОСТЬЮ <--

К-во Просмотров: 209
Бесплатно скачать Курсовая работа: Составить программу на языке Turbo Pascal для параллельной сортировки чисел