Отчет по практике: Язык программирования Pascal

Операторы цикла

Для выполнения некоторого количества повторяющихся действий целесообразно использовать операторы цикла.

Циклы со счетчиком

При использовании цикла со счетчиком следует задать переменную-счетчик. При этом надо помнить, что тип такой переменной должен быть скалярным: Integer, Char, Boolean, перечисляемый тип.

For <начальное значение счетчика> To <конечное значение> Do <тело цикла>;

Счетчик меняется от меньшего к большему с шагом 1

For <начальное значение счетчика> Downto <конечное значение> Do <тело цикла>;

Счетчик меняется от большего к меньшему с шагом 1

Циклы с предусловием

Цикл с предусловием используется для программирования процессов, в которых число повторений оператора цикла не известно, а задается некоторое условие его окончания.

Оператор цикла с предусловием
while <условие> do <тело цикла>;

Выполнение оператора цикла с предусловием начинается с проверки условия, записанного после слова while. Если оно соблюдается, то выполняется <тело цикла>, а затем вновь проверяется условие и т.д. Как только на очередном шаге окажется, что условие не соблюдается, то выполнение <тела цикла> прекратится.

В теле цикла обязательно должен быть оператор, влияющий на соблюдение условия, в противном случае произойдет зацикливание.

Циклы с постусловием.

Для программной реализации циклических процессов с неизвестным числом повторений существует ещё один оператор - оператор цикла с постусловием, который имеет следующий вид:

Оператор цикла с постусловием
Repeat
<оператор 1>;
<оператор 2>;
...
<оператор n>;
Until < условие>;

где Repeat (повторять), Until (до тех пор, пока).

Этот оператор аналогичен оператору цикла с предусловием, но отличается от него тем, что проверка условия производится после очередного выполнения тела цикла. Это обеспечивает его выполнение хотя бы один раз.

Тип данных - это множество величин, объединенных определенной совокупностью доступных операций.

Одномерный массив - последовательность элементов. Число, которых фиксировано и которым присвоено одно имя.

Запись - это структура данных, состоящая из фиксированного числа компьютера, называется полями записи .

Множество в языке программирования Pascal представляет собой ограниченный, неупорядоченный набор различных элементов одного типа .

Строка - это последовательность символов ASCII (таблица кода). При использование в выражениях строка заключается в апострофы.

Двумерный массив -это совокупность данных каждого значения, которых зависит от 2 чисел, которые можно рассматривать как индекс строки, и индекс столбца матрицы.

3. Специальная часть

3.1 Решение задачи

3.1.1 Постановка задачи

Составить программу вычисления суммы n первых членов геометрической прогрессии по любым двум ее членам, номера которых известны.

3.1.2 Таблица идентификаторов

Переменные тип Значения
1 n integer Количество членов геометрической прогрессии
2 b1, b2 real Первый и второй члены геометрической прогрессии
3 Sn real Сумма n членов геометрической прогрессии
4 q real Знаменатель прогрессии

3.1.3 Блок-схема

3.1.4 Программа

Program progressiy;

Var n: integer; b1, b2, Sn, q: real;

Begin

Writeln ('введите n');

Readln (n);

К-во Просмотров: 828
Бесплатно скачать Отчет по практике: Язык программирования Pascal