1.дан текст программы на языке Паскаль. Program test; Car s,i,n:integer; Begin S:=0; For i:=1 to n do s:=s+i;

1.дан текст программы на языке Паскаль. Program test; Car s,i,n:integer; Begin S:=0; For i:=1 to n do s:=s+i; Writeln ('s=',s); End. A)определите значение переменной s после выполнения программы при n=6; Б)для решения какой задачи предназначена программа (сформулируйте условие)? В)по данной программе состав те Блок-схему.
Гость
Ответ(ы) на вопрос:
Гость
Во-первых программа вообще не запуститься, по той причине что паскаль не знает слова car, во второй строчке нужно исправить на var. , вторая ошибка, паскаль вам скажет что S он не знает! а по логике ответом будет s=6 Блок схема ниже!! По программе получается что программа находит наибольшее значение на заданном интервале
Не нашли ответ?
Ответить на вопрос
Похожие вопросы