Дан массив из тридцати элементов. Проверьте, есть ли среди элементов стоящих на четных местах такой, значение которого лежит в интервале от a до b. Если такой элемент существует - напишите YES, иначе напишите NO. Формат входных...
Дан массив из тридцати элементов. Проверьте, есть ли среди элементов стоящих на четных местах такой, значение которого лежит в интервале от a до b.
Если такой элемент существует - напишите YES, иначе напишите NO.
Формат входных данных
На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.
На второй строке записано целые положительные числа a и b.
Формат выходных данных
Строка, содержащая запись YES либо NO
Ответ(ы) на вопрос:
Гость
var
i, x, y: integer;
a: array[1..30]of integer;
begin
readln(x, y);
for i := 1 to 30 do read(a[i]);
for i := 1 to 30 do if (i mod 2 = 0) and (a[i] >= x) and (a[i] <= y) then
begin
write('YES');
exit;
end;
write('NO');
end.
Не нашли ответ?
Похожие вопросы