Даны n целых чисел. Требуется найти их НОД и НОК. Нужно написать программу на Pascal, помогите пожалуйста.

Даны n целых чисел. Требуется найти их НОД и НОК. Нужно написать программу на Pascal, помогите пожалуйста.
Гость
Ответ(ы) на вопрос:
Гость
Var A:array[1..10000] of integer; i,NOD,NOK,k,N:integer; Begin Write('N = ');ReadLn(N); Write('Введите числа (',N,' шт.): '); For i:= 1 to N do     Read(A[i]); {Поиск НОК} NOK:=abs(A[1]); For i:= 2 to N do     if abs(A[i])
Не нашли ответ?
Ответить на вопрос
Похожие вопросы