Добрый день. Помогите, пожалуйста, написать программу для вычисления суммы элементов арифметической и геометрической прогрессии.
Добрый день.
Помогите, пожалуйста, написать программу для вычисления суммы элементов арифметической и геометрической прогрессии.
Ответ(ы) на вопрос:
{программу для вычисления суммы элементов арифметической прогрессии}
var i,j,q,d,n,s,s0,sm:integer;
begin
write('Введите число эле-в, первый элемент и шаг ариф. прогрессиии шаг');
read(n,s0,d);
for i:= 1 to n do begin
s:= s0 +(i-1)*d; write(s:2);
sm:= sm + s;end;
write(sm:4);end.
{программу для вычисления суммы элементов геометрической прогрессии}
var i,j,q,n:integer; z,b,b0,sm:real;
begin
write('Введите число эле-в, первый элемент и знаменатель геом. прогрессиии');
read(n,b0,q);
for i:= 1 to n do begin
z:=i;
b:= b0 *Power(q,z-1);
write(b:4);
sm:= sm + b;end;write(sm:4);end.
var a1,b1,n,d:integer;
sa:real;
begin
writeln('vvedite perviy element arefmeticescoy progressii=');
readln (a1);
writeln('skoliko cisel');
readln(n);
writeln('raznosti arefmeticescoy progressii=');
readln(d);
writeln ( 'summa arefmeticescoy progressii=');
sa:=((2*a1+(n-1)*d)/2)*n;
write(sa);
readln;
end.
______________________________
var i,j,q,n:integer;
z,b,b1,sg:real;
begin
write('vvedite perviy element geometricescoy progressii');
read(b1);
writeln('q=');
readln(q);
writeln('n=');
readln(n);
for i:= 1 to n do
begin
z:=i;
b:= b1 *Power(q,z-1);
sg:= sg + b;
end;
writeln('summa geometricescoy progressii=',sg);
readln;
end.
Не нашли ответ?
Похожие вопросы