На вход программе подаются сведения, из каких школ ученики не сдали книги в библиотеку. Всего в данном городе не более 100 школ.Определить, какая школа имеет наибольшое коичество должников. Количество должников может быть очень...
На вход программе подаются сведения, из каких школ ученики не сдали книги в библиотеку. Всего в данном городе не более 100 школ.Определить, какая школа имеет наибольшое коичество должников. Количество должников может быть очень велико. На входном потоке сначала указывается количество должников, а затем номера их школ
Паскаль ABC
Ответ(ы) на вопрос:
Гость
{Тибетские монахи подсказали мне смысл данного задания, но они могли ошибаться, "астрал затуманен"}
//Pascal ABC.NET v3.1 сборка 1172
Var
maxn,max,a,n:int64;
k,i:byte;
begin
write('Введите количество школ:');
readln(k);
max:=-1;
for i:=1 to k do
begin;
read(n);
readln(a);
if a>max then
begin
max:=a;
maxn:=n;
end;
end;
write('Res=',maxn,' школа с ',max,' должниками');
end.
Пример ввода:
3
12
34554
21
34
335
8568568
Пример вывода:
Res=335 школа с 8568568 должниками
Не нашли ответ?
Похожие вопросы