Надо составить программу ,помогите пожалуйста !!!Очень срочно
Надо составить программу ,помогите пожалуйста !!!Очень срочно
Ответ(ы) на вопрос:
У вас условие неправильно записано в 1 (условие не там), во втором в цикле не "go" а "to", ну да ладно
1
var n,s,a,i:integer;
begin
readln(n);
s:=0;
a:=1;
s:=s+a*a;
a:=a+1;
if a > n
then
writeln(s)
else
begin
s:=s+a*a;
a:=a+1;
end;
end.
2
var n,s,a:integer;
begin
readln(n);
s:=0;
for a:=1 to n do
begin
s:=s+(a*a);
end;
writeln(s);
end.
Не нашли ответ?
Похожие вопросы