Написать программу на Паскале Дана строка текста напечатать все слова,заканчивающиеся на "ов". Если можно,то напишите программу с помощью функции Pos

Написать программу на Паскале Дана строка текста напечатать все слова,заканчивающиеся на "ов". Если можно,то напишите программу с помощью функции Pos
Гость
Ответ(ы) на вопрос:
Гость
Считается, что слова отделяются друг от друга пробелом. var s:string; p:integer; begin writeln('Введите строку:'); readln(s); s:=s+' '; p:=pos(' ',s); while p>0 do  begin  if pos('ов ',s)=p-2 then writeln(copy(s,1,p-1));  delete(s,1,p);  p:=pos(' ',s);  end; end. Пример: Введите строку: пример кров слово шов олово ров кров шов ров
Не нашли ответ?
Ответить на вопрос
Похожие вопросы