Написать программу на языке Паскаль. program lab8; var n,i,fact:integer; s:real; x,a:real; begin write('Введите x='); read(x); write('Введите n='); read(n); fact:=3; s:=1/4; a:=1; for i:=1 to n do begin s:=s+(a*sqr(2*i+1))/(fa...
Написать программу на языке Паскаль.
program lab8;
var
n,i,fact:integer;
s:real;
x,a:real;
begin
write('Введите x=');
read(x);
write('Введите n=');
read(n);
fact:=3;
s:=1/4;
a:=1;
for i:=1 to n do
begin
s:=s+(a*sqr(2*i+1))/(fact*sqr(2*i+2));
fact:=fact*(2*i+1);
a:=a*x;
end;
writeln('s=',s:6:3);
end.
Подскажите где ошибка и что не так
Ответ(ы) на вопрос:
program lab8;
var
n,i,fact:integer;
x,a,s:real;
begin
write('Введите x=');
readln(x);
write('Введите n=');
readln(n);
fact:=1;
s:=1/4;
a:=1;
for i:=2 to n do
begin
fact:=fact*(2*i-2)*(2*i-1);
a:=a*x;
s:=s+(a*sqr(2*i-1))/(sqr(2*i)*fact);
end;
writeln('s=',s:6:3);
end.
Пример:
Введите x=2
Введите n=5
s= 0.462
Не нашли ответ?
Похожие вопросы