Написать программу на языке си++ вычислить сумму ряда до 20 члена s=((-1)*(k!+1)*x^k)/3^k
Написать программу на языке си++ вычислить сумму ряда до 20 члена s=((-1)*(k!+1)*x^k)/3^k
Ответ(ы) на вопрос:
Гость
исходя из вашего запроса:
без отрицания k
#include
using namespace std;
int main()
{
int a,k,s,x;
for (k=0; k<20; k++)
{
s +=((-1)*(k+1)*x^k)/3^k;
}
cout << s << endl;
system("pause"); // или _getch();
return 0;
}
с отрицанием k
#include
using namespace std;
int main()
{
int a,k,s,x;
for (k=0; k<20; k++)
{
s +=((-1)*(k+1)*x^k)/3^k;
}
cout << s << endl;
system("pause"); // èëè _getch();
return 0;
}
и формулируйте вопрос корректнее.
в обоих решениях k=0 изначально
Не нашли ответ?
Похожие вопросы