Написать программу вычисления выражения с помощью цикла for 1!+2!+3!+...+n! уже не соображаю..
Написать программу вычисления выражения с помощью цикла for 1!+2!+3!+...+n!
уже не соображаю..
Ответ(ы) на вопрос:
[latex] var \ i,n,s:integer; \\
function \ fact(a:integer):integer; \\
begin \\
\ if \ a<=1 \ then \ fact:=1 \\
\ else \ fact:=a*fact(a-1); \\
end; \\
\\
begin \\
\ writeln('Vvedite \ n \ '); \\
\ readln(n); \\
\ for \ i:=1 \ to \ n \ do \ s:=s+fact(i); \\
\ writeln('Summa \ ravna \ ',s); \\
end. \\
\ [/latex]
Не нашли ответ?
Похожие вопросы