Написать программу, выводящую на экран таблицу квадратов четных чисел от 0 до 10 в убывающем порядке: 100, 81, 49... Составь блок-схему алгоритма, и напиши программу которая выводит на экране узор, состоящий из звездочек. Долж...

Написать программу, выводящую на экран таблицу квадратов четных чисел от 0 до 10 в убывающем порядке: 100, 81, 49... Составь блок-схему алгоритма, и напиши программу которая выводит на экране узор, состоящий из звездочек. Должно быть 20 строчек со звездочками так, чтобы в каждой последующей строке было на одну звездочку больше. Для вывода на экран строки, со- держащей N звездочек, используй команды String repeatedString = new String('*', N); Console.Write (repeatedString); Microsoft visual studio c#
Гость
Ответ(ы) на вопрос:
Гость
using System; // Написать программу, выводящую на экран таблицу квадратов // четных чисел от 0 до 10 в убывающем порядке: 100, 81, 49... // Составь блок-схему алгоритма, и напиши программу которая // выводит на экране узор, состоящий из звездочек. Должно быть 20 строчек со звездочками так, чтобы в каждой последующей строке было на одну звездочку больше. Для вывода на экран строки, со- держащей N звездочек, используй команды // String repeatedString = new String('*', N); Console.Write (repeatedString); // Microsoft visual studio c# namespace NoNamespace {     internal class Program {         private static void Main() {             SquaresOfNumbersDesc();             Stars(20, 10);             Console.ReadLine();         }         private static void SquaresOfNumbersDesc() {             Console.WriteLine();             for (var i = 10; i >= 0; i = i - 2) {                 Console.Write("{0} ", i * i);             }             Console.WriteLine();         }         private static void Stars(int n, int start_stars) {             Console.WriteLine();             for (var i = 0; i < n; i++) {                 Console.WriteLine(new String('*', start_stars + i));             }             Console.WriteLine();         }     } }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы