Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них. Числа — целые от 1 до 1000. При решении задачи можно пользоваться только целочисленными арифметическими операциями +, -, *, //, %...

Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них. Числа — целые от 1 до 1000. При решении задачи можно пользоваться только целочисленными арифметическими операциями +, -, *, //, %, =. Нельзя пользоваться нелинейными конструкциями: ветвлениями, циклами, функциями вычисления модуля, извлечения квадратного корня. Использование функции max запрещено! Входные данные Вводятся два целых числа a и b. Выходные данные Выведите ответ на задачу. Примеры входные данные 8 5 выходные данные 8 входные данные 5 8 выходные данные 8 входные данные 5 5 выходные данные 5 Заранее спасибо. :-)
Гость
Ответ(ы) на вопрос:
Гость
//Pascal ABC.NET 3.1 сборка 1256 Var  a,b:integer; begin read(a,b); writeln(((a div b)*a+(b div a)*b)/((a div b)+(b div a))); end. Пример ввода: 8 5 Пример вывода: 8
Не нашли ответ?
Ответить на вопрос
Похожие вопросы