ПАСКАЛЬ ДАЮ 34 БАЛЛОВ.ПАСКАЛЬ.Необходимо составить программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 рублей, в 5% — если сумма больше 1 000 рублей. Ф...

ПАСКАЛЬ ДАЮ 34 БАЛЛОВ.ПАСКАЛЬ.Необходимо составить программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 рублей, в 5% — если сумма больше 1 000 рублей. ФОРМАТ ВХОДНЫХ ДАННЫХ: Вводится целое число xx (0≤x≤2 в31 степени −1) — стоимость покупки до скидки. ФОРМАТ ВЫХОДНЫХ ДАННЫХ: Выведите стоимость покупки c учетом скидки в рублях с округлением до целых в меньшую сторону.
Гость
Ответ(ы) на вопрос:
Гость
а врать не хорошо, написано даю 34 балла, а на самом деле 17... айяйяй
Гость
var st,sk:integer; begin readln(st); if st>1000   then sk:=trunc(st*0.95)  else if st>500 then sk:=trunc(st*0.97)                 else sk:=st; writeln(sk); end. Пример: 3000 2850
Не нашли ответ?
Ответить на вопрос
Похожие вопросы