Помогите написать программу для Pascal ABC для нахождения корней дискриминанта

Помогите написать программу для Pascal ABC для нахождения корней дискриминанта
Гость
Ответ(ы) на вопрос:
Гость
program z1;  var a,b,c,D:real;  begin  writeln('Vvedite a');  readln(a);  writeln('Vvedite b');  readln(b);  writeln('Vvedite c');  readln(c);  D:=(b*b)-(4*a*c);  writeln('Discriminant');  writeln(D:1:2);  D:=(-b+sqrt(D))/(2*a);  writeln('1 koren');  writeln(D:1:2);  D:=(-b-sqrt(D))/(2*a);  writeln('2 koren');  writeln(D:1:2);  readln  end.
Гость
program korni; var a,b,c,d,x1,x2:real; begin writeln('введите a'); readln(a); writeln('введите b'); readln(b); writeln('введите c'); readln(c); writeln('Вычисляем дискриминант'); d:=b*b-4*a*c; writeln('d=',d ); if d>0 then x1:=(-b+sqrt(d)/2*a); x2:=(-b-sqrt(d)/2*a); writeln('x1=',x1); writeln('x2=',x2); if d=o then  x1:=(-b+sqrt(d)/2*a); writeln('один корень - x1=',x1); if d<0 then writeln('нет корней'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы