Помогите написать программу к задаче!!! Даны действительные числа A1,A2,...An.Найти:max(A1+A2,A2+A3,...An-1+An).
Помогите написать программу к задаче!!! Даны действительные числа A1,A2,...An.Найти:max(A1+A2,A2+A3,...An-1+An).
Ответ(ы) на вопрос:
сначала надо алгоритм решения построить: Суть заключаеться в том, чтобы в цикле от 1 до n-1 присваивать некоторому значению MAX максимальное из (MAX,mas[i ]+mas[i+1]); А уж как записать - ето вопрос на каком языке вы будете писать программу. Могу на паскале написать код программы: var max,i,n:integer; mas: array[1..100] of integer; begin readln(n); for i:=1 to n do read(mas[i ]); for i:=1 to n-1 do if max < (mas[i ]+mas[i+1]) then max:=mas[i ]+mas[i+1]; writeln(max) end. Там в скобках, когда mas[i ] - пробел в скобках, потомучто мейлру считает ето орматированием текста на курсив.
Не нашли ответ?
Похожие вопросы