Помогите написать программу на паскаль и блок схемуНайти сумму1,1-1,2+1,3.......1.nn- целое, вводится с клавиатуры i- параметр циклаj- меняет знак j:=-j
Помогите написать программу на паскаль и блок схему
Найти сумму
1,1-1,2+1,3.......1.n
n- целое, вводится с клавиатуры
i- параметр цикла
j- меняет знак j:=-j
Ответ(ы) на вопрос:
var
i,j,s,n:integer;
begin
write('Задайте значение n: ');
readln(n);
s:=1;
j:=-1;
for i:=1 to n do
begin
s:=s+i+j;
j:=-j
end;
writeln('s=',s);
end.
Тестовое решение:
Задайте значение n: 5
s=15
Не нашли ответ?
Похожие вопросы