Помогите пожалуйста. Даны две точки на плоскости. Напишите программу, определяющую какая из этих точек находится ближе к началу координат.
Помогите пожалуйста.
Даны две точки на плоскости. Напишите программу, определяющую какая из этих точек находится ближе к началу координат.
Ответ(ы) на вопрос:
Гость
function VectorLength(x, y: real): real;
begin
VectorLength := sqrt(x * x + y * y);
end;
var
x1, x2, y1, y2: real;
begin
readln(x1, y1);
readln(x2, y2);
if VectorLength(x1, y1) > VectorLength(x2, y2) then
writeln('Point1')
else writeln('Point2');
end.
Не нашли ответ?
Похожие вопросы