Распишите. 1.определите значение целочисленных переменных x и y после выполнения фрагмента программы х := 19; у := 3; z := у*2; у := х mod у; х := х - z; у := у + z;
Распишите. 1.определите значение целочисленных переменных x и y после выполнения фрагмента программы х := 19;
у := 3;
z := у*2;
у := х mod у;
х := х - z;
у := у + z;
Ответ(ы) на вопрос:
var
x, y, z: integer ;
begin
x := 19;
y := 3;
z := y * 2;
y := x mod y;
x := x - z;
y := y + z;
writeln('x = ', x, ', y = ', y, ', z = ', z);
end.
Вывод
x = 13, y = 7, z = 6
Не нашли ответ?
Похожие вопросы