Составить программу Дано трехзначное число. Верно ли, что: 1. сумма его цифр-число четное 2. цифры в числе располодены по возрастанию 3. в запись числа входит цифра 5 4. оно оканчивается на цифру 7
Составить программу
Дано трехзначное число. Верно ли, что:
1. сумма его цифр-число четное
2. цифры в числе располодены по возрастанию
3. в запись числа входит цифра 5
4. оно оканчивается на цифру 7
Ответ(ы) на вопрос:
var a,z,s,i,m:integer;
begin
readln(a);
s:=0;
z:=a;
for i:=1 to 3 do begin
s:=s+(z mod 10);
z:=z div 10;
end;
if s mod 2 = 0 then writeln('1. Верно')else writeln('1. Неверно');
z:=a;
s:=z mod 10;
z:=z div 10;
m:=0;
for i:=1 to 2 do begin
if s < z mod 10 then begin
m:=1;
break;
end
else begin
s:=z div 10;
z:=z div 10;
end;
end;
if m = 0 then writeln('2. Верно')else writeln('2. Неверно');
z:=a;
m:=0;
for i:=1 to 3 do begin
if z mod 10 = 5 then begin
m:=1;
break;
end else begin
z:=z div 10;
end;
end;
if m = 1 then writeln('3. Верно')else writeln('3. Неверно');
if a mod 10=7 then writeln('4. Верно')else writeln('4. Неверно');
end.
Не нашли ответ?
Похожие вопросы