Составить программу для Pascal ABC, печатающую значение true, если указанное высказывание является истинным, и false в противном случае, когда данная тройка натуральных чисел a, b, c является тройкой Пифагора, т.е. c^2 = a^2 + ...
Составить программу для Pascal ABC, печатающую значение true, если указанное высказывание является истинным, и false в противном случае, когда данная тройка натуральных чисел a, b, c является тройкой Пифагора, т.е. c^2 = a^2 + b^2.
Ответ(ы) на вопрос:
uses crt;
var
t1:boolean;
a, b, c: integer;
begin
readln(a, b, c);
if c*c=a*a+b*b then t1:= true else t1:= false;
writeln (t1);
readkey;
end.
Не нашли ответ?
Похожие вопросы