Составить программу поиска элементов массива, значение которых совпадает с индексом.
Составить программу поиска элементов массива, значение которых совпадает с индексом.
Ответ(ы) на вопрос:
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace ConsoleApplication4
{
class Program
{
static void Main(string[] args)
{
Console.WriteLine("Введи длину массива");
int n = int.Parse(Console.ReadLine());
int[] mass = new int[n];
for (int i = 0; i < n; i++)
{
Console.WriteLine("Введи " + i + " элемент");
mass[i] = int.Parse(Console.ReadLine());
}
for (int i = 0; i < n; i++)
{
if (i == mass[i])
Console.WriteLine("Элемент " + i + " совпадает со своим индексом");
}
Console.ReadKey();
}
}
}
Не нашли ответ?
Похожие вопросы