Составить программу в Паскале:Из n введенных чисел найти максимальное значение среди положительных элементов.

Составить программу в Паскале: Из n введенных чисел найти максимальное значение среди положительных элементов.
Гость
Ответ(ы) на вопрос:
Гость
Текст программы в документе.
Гость
program abc; type     mas = array[0..1000] of integer; var     a: mas;    i, n, max: integer; begin   WriteLn('Введите кол-во эл-тов массива:');   ReadLn(n);   for i := 1 to n do   begin     WriteLn('Введите значение элемента №', i);     ReadLn(a[i]);   end;   WriteLn('Все элементы массива имеют значение');   max := -1;   for i := 1 to n do     if a[i] > max then       max := a[i];     if max <> -1 then       Writeln('Максимальное значение положительного элемент = ', max)     else Writeln('Положительных элементов нет');     ReadLn; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы