Составьте программу произведения первой и третьей и суммы второй и четвертой цифры четырехзначного числа (Паскаль)

Составьте программу произведения первой и третьей и суммы второй и четвертой цифры четырехзначного числа (Паскаль)
Гость
Ответ(ы) на вопрос:
Гость
program zadacha; var a,p,s:integer; begin writeln('Введите четырехзначное число'); readln(a); p:=(a div 1000)*(a mod 100 div 10); s:=(a div 100 mod 10)+(a mod 10); writeln('Произведение первой и третьей =',p); writeln('Сумма второй и четвертой = ',s) end.
Гость
program programma; var a,b,c,d,e,p,s: integer; begin writeln ('Введите четырехзначное число'); readln (a); b:=a div 1000; c:=a div 100; c:=c mod 10; d:=a mod 100; d:=d div 10; e:=a mod 10; p:=b*d; s:=c+e; writeln ('Произведение первой и третьей цифры равно ',p,', сумма второй и четвертой цифры равна ',s); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы