Задание 1. Заполнение массива от a до b Дан массив из 30 элементов. Заполнить массив начиная с элемента a до элемента b двойками, а остальные элементы нулями и вывести весь массив на экран. Известно, что 1 меньше =a Формат вв...

Задание 1. Заполнение массива от a до b Дан массив из 30 элементов. Заполнить массив начиная с элемента a до элемента b двойками, а остальные элементы нулями и вывести весь массив на экран. Известно, что 1<=a Формат ввода Вводятся 2 целых числа 1<=a Формат вывода Массив из 30 элементов Пример Ввод 2 10 Вывод 0 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 в Паскале ABC ( не обновленном )
Гость
Ответ(ы) на вопрос:
Гость
Var M:array[1..30] of integer; i,a,b:integer; Begin Read(a,b); For i:= 1 to a-1 do     M[i]:=0; For b:= a to b do     M[b]:=2; For i:= b+1 to 30 do     M[i]:=0; For i:= 1 to 30 do     Write(M[i],' ') End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы