Задание: Вы ввели трехзначное число. Составьте программу, определяющую, есть ли в этом числе, четные цифры. Вопрос: в какой программе решается данная задача и каким образом?
Задание: Вы ввели трехзначное число. Составьте программу, определяющую, есть ли в этом числе, четные цифры.
Вопрос: в какой программе решается данная задача и каким образом?
Ответ(ы) на вопрос:
Лучше всего сделать в pascal.
Попробуй этот код:
var n: integer; boo: boolean;begin write('Введите число: '); readln(n); boo:=odd(n); case boo of true: writeln('Нечетное'); false: writeln('Четное'); end; readln;end.
program OddNumeric;
var
n, i: integer;
a: array [1..3] of byte;
b: boolean;
begin
Write('Введите трехзначное число: ');
Readln(n);
a[1]:=n div 100; {1 цифра сотен}
a[2]:=(n div 10) mod 10; {2 цифра десятков}
a[3]:=n mod 10; {3 цифра количество единиц}
b:=false;
for i:=1 to 3 do
begin
if (a[i] mod 2)=0 then
b:=true;
end;
if b then
Writeln('В этом числе есть четные цифры')
else
Writeln('В этом числе нет четных цифр');
end.
Не нашли ответ?
Похожие вопросы