Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный...

Задать массив из n элементов. Значения вести с клавиатуры. Написать программу, уменьшающую все элементы массива на единицу. Вывести на экран массив дважды; сначала исходный массив (в строку), а затем с новой строки - полученный массив. Для перехода на новую строку добавить writeln. Это все в pascal abc
Гость
Ответ(ы) на вопрос:
Гость
const n=10000; var a:array [1..n] of integer; b:array [1..n] of integer; i, k:integer; begin Writeln ('Введите число элементов массива'); readln (k); for i:=1 to k do begin Writeln ('Введите ',i,' элемент массива'); readln (a[i]); end; for i:=1 to k do begin b[i]:=a[i]-1; end;  Writeln ('Первоначальный массив:');  for i:=1 to k do begin writeln (a[i]); end;  Writeln ('Конечный массив:');  for i:=1 to k do begin writeln (b[i]); end;  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы