1 Дано слово ,,КОМПЬЮТЕР". Составить программу получения слов ,,КОМ", ,, РЕТРО'', ,, РОК", используя только буквы исходного слова. 2 Задана исходная строка ,,КОМПЬЮТЕР''. Поменять местами i и последний символ строки. Номер i за...

1 Дано слово ,,КОМПЬЮТЕР". Составить программу получения слов ,,КОМ", ,, РЕТРО'', ,, РОК", используя только буквы исходного слова. 2 Задана исходная строка ,,КОМПЬЮТЕР''. Поменять местами i и последний символ строки. Номер i задаётся пользователем . 3 Составить программу шифрования слова ,,ПАР", используя шифр Цезаря (со сдвигом на 4 позиции). составить в Паскале
Гость
Ответ(ы) на вопрос:
Гость
*** 1 *** // PascalABC.NET 3.1, сборка 1267 от 10.07.2016 begin   var w:='КОМПЬЮТЕР';   Writeln(w[1:4]);   Writeln((w.Right(3).Inverse)+w[w.Length]+w[2]);   Writeln(w[w.Length]+w[2::-1]) end. Результат КОМ РЕТРО РОК *** 2 *** // PascalABC.NET 3.1, сборка 1267 от 10.07.2016 begin   var w:='КОМПЬЮТЕР';   var i:=ReadInteger('i=');   Swap(w[i],w[w.Length]);   Writeln(w) end. Тестовое решение i= 5 КОМПРЮТЕЬ *** 3 *** // PascalABC.NET 3.1, сборка 1267 от 10.07.2016 begin   var w:='ПАР'; // исходное слово   var k:=4; // константа сдвига шифра Цезаря   var a:='АБВГДЕЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯАБВГ';   for var i:=1 to w.Length do begin     var p:=Pos(w[i],a);     if p>0 then w[i]:=a[p+k]     end;   Writeln(w) end. Результат УДФ
Не нашли ответ?
Ответить на вопрос
Похожие вопросы