1. Найдите наибольший элемент одномерного массива, состоящего из 12 элементов. Элементы задаются датчиком случайных чисел из интервала [-25,31] 2. Массив А вводится с клавиатуры. Найдите произведение отрицательных элементов с в...
1. Найдите наибольший элемент одномерного массива, состоящего из 12 элементов. Элементы задаются датчиком случайных чисел из интервала [-25,31]
2. Массив А вводится с клавиатуры. Найдите произведение отрицательных элементов с выводом на экран массива А
Ответ(ы) на вопрос:
1. в C++
#include
#include
int main()
{
using namespace std;
int ar[12];
srand(time(0));
for (int i = 0; i < 12; i++)
ar[i] = -25 + rand() % 57;
int temp = ar[0];
for (int i = 0; i < 12; i++)
if (ar[i] > temp)
temp = ar[i];
for (int i = 0; i < 12; i++)
cout << ar[i] << " ";
cout << endl;
cout << "Max: " << temp;
cout << endl;
return 0;
}
Не нашли ответ?
Похожие вопросы