1.дано целое число n больше -10 составьте программу которая вычисляет сумму через от -10 до n 2.дано целое число n (n меньше 100) составьте программу которая вычисляет среднее арифметическое чисел от n до 100 3.дано целое число...
1.дано целое число n>-10 составьте программу которая вычисляет сумму через от -10 до n
2.дано целое число n (n<100) составьте программу которая вычисляет среднее арифметическое чисел от n до 100
3.дано целое число n>10 составьте программу которая вычисляет сумму через от 10 до n
4.даны действительное число a, натуральное число n, составьте программу которая вычисляет a^n Операцию в возведения в степень не использовать
5. даны целые числа n и m(n
Ответ(ы) на вопрос:
1.
program myprogram;
var n : integer;
a1, a2 : real;
begin readln(n);
writeln((n + 11) * (n - 10) div 2);
end.
2.
program myprogram;
var n : integer;
a1, a2 : real;
begin readln(n);
writeln(((100 - n + 1) * (n + 100) div 2) / (100 - n + 1));
end.
3.
program myprogram;
var n : integer;
a1, a2 : real;
begin readln(n);
writeln((n - 9) * (n + 10) div 2);
end.
4.
program myprogram;
var
n, i : integer;
a1, a2 : real;
begin
read(n);
read(a1);
a2:=a1;
for i:=1 to n do a1:=a1*a2;
writeln(a1);
end.
5.
program myprogram;
var
n,m, i, ans : integer;
begin
read(n);
read(m);
ans:=0;
for i:=n to m do ans := ans + i*i;
writeln(ans);
end.
6.
program myprogram;
var
n, i, ans : integer;
begin
read(n);
ans:=0;
for i:=n to 2*n do ans := ans + i*i;
writeln(ans);
end.
Не нашли ответ?
Похожие вопросы