1. Составить программу, которая каждый элемент массива увеличивает на его порядковый номер.
1. Составить программу, которая каждый элемент массива увеличивает на его порядковый номер.
Ответ(ы) на вопрос:
program p1;
var a:array[1..10] of integer;
i:integer;
begin
randomize;
for i:=1 to 10 do a[i]:=random(10);
writeln('Массив:');
for i:=1 to 10 do writeln('a[',i,']=',a[i]);
for i:=1 to 10 do a[i]:=a[i]+i;
writeln('Результат:');
for i:=1 to 10 do writeln('a[',i,']=',a[i]);
end.
Не нашли ответ?
Похожие вопросы