3. Напишите программу, которая подсчитывает, сколько чисел из последовательности делятся на 3 и при этом заканчиваются на 4. На выход программа получает сначала количество чисел в последовательности, а затем сами числа по одном...
3. Напишите программу, которая подсчитывает, сколько чисел из последовательности делятся на 3 и при этом заканчиваются на 4. На выход программа получает сначала количество чисел в последовательности, а затем сами числа по одному. Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 4.
Входные данные/Выходные данные
8/4
12/
14/
24/
54/
44/
33/
84/
114/
Ответ(ы) на вопрос:
Гость
var
a:array[1..1000]of integer;
i,n,k,c,q:integer;
begin
readln(n);
for i:=1 to n do
begin
readln(a[i]);
if (a[i] mod 10 = 4) then
begin
k:=a[i];
c:=0;
while k>0 do
begin
c:=c + k mod 10;
k:= k div 10;
end;
if c mod 3 = 0 then
q:=q+1;
end;
end;
writeln(q);
end.
Не нашли ответ?
Похожие вопросы