6. Составить алгоритм и написать программу вычисления суммы и среднего значения т?

6. Составить алгоритм и написать программу вычисления суммы и среднего значения т??лько отрицательных чисел из вводимых N произвольных (как положительных, так и отрицательных) целых чисел.N не больше 10
Гость
Ответ(ы) на вопрос:
Гость
Var a:array[1..100] of integer; i,n,s,k:integer; begin  s:=0; k:=0; write('Введите кол-во чисел: '); readln(n); write('Введите числа: ');  for i:=1 to n do read(a[i]); for i:=1 to n do if a[i]<0 then begin s:=s+a[i]; inc(k); end; if k<>0 then  begin writeln('Ср.знач. отрицательных чисел: ',s/k); writeln('Сумма отрицательных чисел: ',s); end  else writeln('Отрицательных членов нет'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы