А)Составить программу, которая увеличивает в 10 раз все элементы массива. б) заменя?

А)Составить программу, которая увеличивает в 10 раз все элементы массива. б) заменя??т все отрицательные элементы их индексами. Сделать нужно и а и б. Через паскаль. Очень прошу, помогите пожалуйста. Прошу, пожалуйста помогите, срочно, очень надо.
Гость
Ответ(ы) на вопрос:
Гость
//PascalABC.NET 3.2 сборка 1318 //а begin   writeln('Введите размерность:');   var n:=ReadInteger();   writeln('Введите массив:');   var ar:=ReadArrInteger(n);   ar.Transform(x -> x*10);   ar.Print; end. //б begin   writeln('Введите размерность');   var n:=ReadInteger();   writeln('Введите массив:');   var ar:=ReadArrInteger(n);   for var i:=0 to n-1 do            //индексация с 0     if ar[i]<0 then ar[i]:=i;   ar.Print; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы