Аx^2+Вx+С=0 Написать программу нахождения действительных корней этого уравнения на Pascal
Аx^2+Вx+С=0
Написать программу нахождения действительных корней этого уравнения на Pascal
Ответ(ы) на вопрос:
Program z1;
Uses CRT;
Var a,b,c,d,x1,x1: real;
Begin
Clrscr;
Write('введите a,b,c'); readln(a,b,c);
D:=b*b-4*a*c;
If d>=0 then
Begin
X1:=(-b+sqrt(d))/(2*a);
Х2:=(-b-sqrt(d))/(2*a);
Writeln('x1=',x1' x2=',x2);
END;
Else writeln('действительных корней нет');
End.
Не нашли ответ?
Похожие вопросы