Чуваки, помогите. Не шарю совсем, надо написать программу и лучше с объяснениями. Дано натуральное число. Верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)

Чуваки, помогите. Не шарю совсем, надо написать программу и лучше с объяснениями. Дано натуральное число. Верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
Гость
Ответ(ы) на вопрос:
Гость
Требуемая программа: var n,a: longint; b: boolean; begin readln(n); readln(a); b:=false; while n>0 do  begin  if n mod 10 = a then b:=true;  n:=n div 10;  end; if b   then writeln('В числе есть введенная цифра')  else writeln('В числе нет введенной цифры'); end. Пример: 1236548 2 В числе есть введенная цифра
Не нашли ответ?
Ответить на вопрос
Похожие вопросы