ДАМ 40!!! БАЛЛОВ!!! ПОМОГИТЕ!!! Написать программу, в которой вводится последовательность целых чисел, оканчивающаяся нулем (т.е. признак окончания ввода чисел в последовательности – ввод нуля). Программа должна посчитать и выв...
ДАМ 40!!! БАЛЛОВ!!! ПОМОГИТЕ!!!
Написать программу, в которой вводится последовательность целых чисел, оканчивающаяся нулем (т.е. признак окончания ввода чисел в последовательности – ввод нуля). Программа должна посчитать и вывести количество отрицательных чисел в этой последовательности. Программу реализовать двумя способами: при помощи цикла с пред- и пост- условием.
Ответ(ы) на вопрос:
var
number: integer;
k: integer;
begin
repeat
write('number = ');
readln(number);
if number < 0 then k := k + 1;
until number = 0;
writeln('Кол-во отрицательных = ', k);
end.
Не нашли ответ?
Похожие вопросы