Дан массив целых чисел из 10 элементов поменять местами первый максимальный и последний отрицательный элементы массива. Составить программу в паскале
Дан массив целых чисел из 10 элементов поменять местами первый максимальный и последний отрицательный элементы массива. Составить программу в паскале
Ответ(ы) на вопрос:
Гость
Var
A:array[1..10] of integer;
i,m,o:integer;
Begin
WriteLn('Введите массив');
For i:= 1 to 10 do
Begin
Read(A[i]);
End;
m:=10;
For i:= 9 downto 1 do
if A[i]>=A[m] then m:=i;
For i:= 10 downto 1 do
if A[i]<0 then
Begin
o:=i;
Break
End;
if o = 0 then WriteLn('Отрицательных чисел нет!')
else
Begin
i:=A[o];
A[o]:=A[m];
A[m]:=i;
For i:= 1 to 10 do
Write(A[i],' ')
End;
End.
Не нашли ответ?
Похожие вопросы