Дан одномерный массив целых чисел, состоящий из 20 ячеек, заполненный случайными числами из промежутка [-9,9]. Найти количество ячеек, с нечетными номерами, которые содержат число --5. Напишите программу со всеми объяснениями п...
Дан одномерный массив целых чисел, состоящий из 20 ячеек, заполненный случайными числами из промежутка [-9,9]. Найти количество ячеек, с нечетными номерами, которые содержат число --5. Напишите программу со всеми объяснениями пожалуйста!
Ответ(ы) на вопрос:
var
a:array[1..20]of integer;
i,n,c:integer;
begin
for i:=1 to 20 do
begin
a[i]:=random(19)-9;
write(a[i],' ');
if i mod 2 =1 then
if a[i]=-5 then
c:=c+1;
end;
writeln;
writeln(c);
end.
Не нашли ответ?
Похожие вопросы