Дан целочисленный массив из 20 элементов. Элементы массива могут быть целыми числами от -1000 до 1000. Найдите минимальный элемент среди положительных, делящихся на 3 и нечетных

Дан целочисленный массив из 20 элементов. Элементы массива могут быть целыми числами от -1000 до 1000. Найдите минимальный элемент среди положительных, делящихся на 3 и нечетных
Гость
Ответ(ы) на вопрос:
Гость
uses crt; const n=20; var i,min:integer; a:array [1..n]   of integer; begin randomize; for i:=1 to n do  a[i]:= random(2001)-1000; {read (a[i])}{ручной ввод чисел} min:=1001; for i:=1 to n   do if (a[i]>0)  and (a[i]mod 3=0) and (odd(a[i])) and (a[i]1001 then  writeln(min) else   writeln('нет чисел удовлетворяющих заданному условию'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы