Дана строка ,содержащее слово,записанное через дефис. написать программу ,которая вставляет пробелы перед и после дефиса. помогите пожалуйста!

Дана строка ,содержащее слово,записанное через дефис. написать программу ,которая вставляет пробелы перед и после дефиса. помогите пожалуйста!
Гость
Ответ(ы) на вопрос:
Гость
var s: string;     i: integer; begin    write('строка:  ');    readln(s);     i:=1;    while i<=length(s) do    begin      if s[i]='-' then      begin        s:=copy(s,1,i-1)+' '+s[i]+' '+        copy(s,i+1,length(s)-i+3);        i:=i+2;     end;     i:=i+1;   end;   writeln('новая строка:  ',s); end.     
Не нашли ответ?
Ответить на вопрос
Похожие вопросы