Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа...

Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных. вывести новые числа.
Гость
Ответ(ы) на вопрос:
Гость
Не самый рациональный метод решения, но как говорится чем смог тем помог) var a,b,c,x,kc,kn,k1,k2:integer;  begin  kc:=1;  kn:=1;  k1:=0;  k2:=0;  a:=0;  b:=0;  writeln('Введите число x');  read(x);  while x>0 do begin  c:=x mod 10;  if c mod 2=0 then begin  inc(k1);  a:=a+c*kc;  kc:=kc*10;  end;  if c mod 2<>0 then begin  inc(k2);  b:=b+c*kn;  kn:=kn*10;  end;  x:=x div 10;  end;  if k1>k2 then writeln('Четных больше нечетных') else if k1=k2 then writeln('Количество четных = количеству нечетных') else writeln('Четных меньше нечетных');  writeln(a,' ', b);  end. 
Не нашли ответ?
Ответить на вопрос
Похожие вопросы