Даю 20 баллов. Программа PascalABC задача:написать программу для подсчета суммы только положительных,из 3 данных чисел.
Даю 20 баллов. Программа PascalABC задача:написать программу для подсчета суммы только положительных,из 3 данных чисел.
Ответ(ы) на вопрос:
var a, s, i:integer;
begin
s:=0;
for i:=1 to 3 do
begin
write('Введите число: ');
readln(a);
if a>0 then s:=s+a;
end;
writeln('Сумма положительных чисел: ', s)
end.
var a,b,c,sum:integer;
begin
writeln('Введите три числа:');
read(a,b,c);
if a>0 then sum:=sum+a;
if b>0 then sum:=sum+b;
if c>0 then sum:=sum+c;
writeln('Сумма положительных чисел равна ',sum);
end.
Не нашли ответ?
Похожие вопросы