И снова я, и снова мой любимый Паскаль.. Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива. Входные данные Сначала задано число N — количество ...

И снова я, и снова мой любимый Паскаль.. Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива. Входные данные Сначала задано число N — количество элементов в массиве (1 Выходные данные Необходимо единственное число - количество положительных элементов в массиве. Написал: program u1; var i,n,k:longint; a:array[1..10000] of longint; begin readln(n); for i:=1 to n do readln (a[i]); for i:= 1 to n do write( 'a[i]=',a[i],' ');writeln; for i:= 1 to n do begin if a[i]>0 then k:=k+1;end; writeln(k); end. но тем не менее, решено не правильно. Пожалуйста, посмотрите.
Гость
Ответ(ы) на вопрос:
Гость
program qq; var col, out, i: integer; arr: array[1..100] of integer; begin write('Количество элементов: '); readln(col); write('Введите числа: '); out := 0; for i := 1 to col do readln(arr[i]); writeln; write('Положительных чисел: '); for i := 1 to col do begin if(arr[i] > 0) then out := out + 1; end; write(out); end. ----- В вашем же решении вы не указали переменную k, т.е. у вас нет k := 0; и после выполнения условия if не нужно писать end;
Не нашли ответ?
Ответить на вопрос
Похожие вопросы