Информатика 10 кл Паскаль Массив содержит четное количество элементов.Напишите программу,которая сортирует первую половину массива по возрастанию,а вторую по убыванию.Каждый элемент должен остаться в "своей" половину. Заранее с...
Информатика 10 кл Паскаль
Массив содержит четное количество элементов.Напишите программу,которая сортирует первую половину массива по возрастанию,а вторую по убыванию.Каждый элемент должен остаться в "своей" половину.
Заранее спасибо;)
Ответ(ы) на вопрос:
Const
N = 10;
Var
A:array[1..N] of integer;
i,j:integer;
Begin
Write('Исходный массив: ');
For i:= 1 to N do
Begin
A[i]:=random(21)-10;
Write(A[i],' ')
End;
WriteLn;
Write('Отсортированный массив: ');
For j:= 1 to N div 2 do
For i:= 1 to N div 2-1 do
if A[i]>A[i+1] then Swap(A[i],A[i+1]);
For j:= 1 to N div 2 do
For i:= N div 2 to N-1 do
if A[i]
Не нашли ответ?
Похожие вопросы