Информатика.Паскаль.Задача.Известны координаты вершин A,B,C треугольника.Составить программу в паскале,вычисляющую площадь этого треугольника.Где:xa=2,ya=1,xb=6,yb=5,xc=10,yc=1
Информатика.Паскаль.Задача.Известны координаты вершин A,B,C треугольника.Составить программу в паскале,вычисляющую площадь этого треугольника.Где:xa=2,ya=1,xb=6,yb=5,xc=10,yc=1
Ответ(ы) на вопрос:
var xa,ya,xb,yb,xc,yc,S:real;
begin
readln(xa,ya,xb,yb,xc,yc);
S:=abs(((xb-xa)*(yc-ya)-(xc-xa)*(yb-ya))/2);
writeln(s);
readln;
end.
На паскале проверил, все отлично работает!:)
Не нашли ответ?
Похожие вопросы